Defect #27102

Internal Error when deleting user - Redmine 3.4.2

Added by Chris D 3 months ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Accounts / authentication
Target version:-
Resolution:Invalid Affected version:3.4.2

Description

Hi, just upgraded to Redmine 3.4.2. When doing some initial testing tried deleting a user and got

Internal error

An error occurred on the page you were trying to access.
If you continue to experience problems please contact your Redmine administrator for assistance.

If you are the Redmine administrator, check your log files for details about the error.

Checked the production.log and see this error:

ActiveRecord::StatementInvalid (Mysql2::Error: Unknown column 'projects.default_assigned_to_id' in 'where clause': UPDATE `projects` SET `projects`.`default_assigned_to_id` = NULL WHERE `projects`.`default_assigned_to_id` = 9):
app/models/principal.rb:185:in `nullify_projects_default_assigned_to'
app/controllers/users_controller.rb:169:in `destroy'
lib/redmine/sudo_mode.rb:63:in `sudo_mode'

Any ideas what the issue is? Fixes?

TIA,
Chris

History

#1 Updated by Go MAEDA 3 months ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Probably you didn't run db:migrate during upgrading process. Please read RedmineUpgrade.

Also available in: Atom PDF