Defect #27861

bundle install fails for nokogiri 1.7.2 (x64-mingw32) and ruby 2.4.3 on Windows

Added by Kenan Dervisevic 4 months ago. Updated 4 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Ruby support
Target version:-
Resolution:Duplicate Affected version:3.4.3

Description

bundle install command fails for nokogiri 1.7.2 (x64-mingw32) and ruby 2.4.3 on Windows with the following message:

Ruby version installed: ruby 2.4.3p205 (2017-12-14 revision 61247) [x64-mingw32] (from rubyinstaller.org)

According to https://github.com/sparklemotion/nokogiri/issues/1618, nokogiri 1.8.0 fixes this. I've bumped the version to 1.8.0 in Gemfile and it did the trick.

nokogiri.png (20 KB) Kenan Dervisevic, 2017-12-28 13:37


Related issues

Duplicates Redmine - Defect #27505: Cannot install nokogiri 1.7 on Windows Ruby 2.4 Closed

History

#1 Updated by Toshi MARUYAMA 4 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #27505.

#2 Updated by Toshi MARUYAMA 4 months ago

  • Duplicates Defect #27505: Cannot install nokogiri 1.7 on Windows Ruby 2.4 added

Also available in: Atom PDF