Defect #28414

Does Redmine compatible with MySQL 5.7 or not ?

Added by Gena Makhomed over 1 year ago. Updated 11 months ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Database
Target version:-
Resolution:Duplicate Affected version:3.4.4

Description

On page https://github.com/redmine/redmine/blob/master/doc/INSTALL
we can read what Redmine tested with MySQL 5.7 and should work fine with this version.

But on page http://www.redmine.org/projects/redmine/wiki/RedmineInstall
we can read what Redmine is not compatible with MySQL 5.7

Does Redmine compatible with MySQL 5.7 or not ? On which page written truth?

If Redmine is not compatible with MySQL 5.7 - how it is possible to use Redmine with Ubuntu 16.04 ?
Ubuntu 16.04 was packaged with MySQL 5.7 and have no way to use older MySQL version 5.0 - 5.5

Can you please make Redmine fully compatible with MySQL 5.7 ?


Related issues

Duplicates Redmine - Feature #17460: MySQL 5.7 support New

History

#1 Updated by Simon Deziel over 1 year ago

Redmine works well with MySQL 5.7. I'm running multiple instances on Ubuntu 16.04 and never ran into a problem.

#2 Updated by Gena Makhomed over 1 year ago

Simon Deziel wrote:

Redmine works well with MySQL 5.7. I'm running multiple instances on Ubuntu 16.04 and never ran into a problem.

In page http://www.redmine.org/projects/redmine/wiki/RedmineInstall

you can read what Supported database back-ends are only MySQL 5.0 - 5.5
and what MySQL 5.6 or higher and MariaDB have known issues (#19344, #19395, #17460).

Until these issues are not resolved - MySQL 5.7 is not compatible with Redmine 3.4
and MySQL 5.7 is not supported.

#3 Updated by Marius BALTEANU 11 months ago

#4 Updated by Marius BALTEANU 11 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

I’m closing this in favour of #17460.

Also available in: Atom PDF