Defect #30114

Installing xpath with Bundler fails in Ruby <=2.2

Added by Go MAEDA 8 months ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Gems support
Target version:3.4.9
Resolution:Fixed Affected version:3.3.7

Description

"bundle install" and "bundle update" fails in Ruby <=2.2 because the recent versions of xpath gem require newer Ruby.

xpath version Required Ruby version
3.2.0 (2018-10-15) >= 2.3
3.1.0 (2018-05-26) >= 2.2
3.0.0 (2017-12-30) >= 2.2
2.1.0 (2017-05-25) >= 1.9.3

Related issues

Duplicated by Redmine - Defect #30716: latest version of xpath gem need ruby 2.3 Closed

Associated revisions

Revision 17854
Added by Go MAEDA 5 months ago

Use xpath < 3.2 for Ruby < 2.3 (#30114).

Patch by Go MAEDA.

Revision 17855
Added by Go MAEDA 5 months ago

Use xpath < 3.2 for Ruby < 2.3 (#30114).

Patch by Go MAEDA.

History

#1 Updated by Go MAEDA 8 months ago

Gem::InstallError: xpath requires Ruby version >= 2.3.
An error occurred while installing xpath (3.2.0), and Bundler cannot continue.
Make sure that `gem install xpath -v '3.2.0'` succeeds before bundling.

#2 Updated by Go MAEDA 6 months ago

  • Duplicated by Defect #30716: latest version of xpath gem need ruby 2.3 added

#3 Updated by Go MAEDA 5 months ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Target version set to 3.4.9
  • Resolution set to Fixed

Committed the fix for 4.0-stable and 3.4-stable. Now xpath < 3.2 is installed for Ruby < 2.3.

Also available in: Atom PDF