Defect #31737

Unable to get csv export

Added by Taylor Naungayan about 1 month ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution: Affected version:4.0.3

Description

We are getting a 500 error when we are trying export a csv.

Started GET "/projects/stw-ca/issues.csv?utf8=%E2%9C%93&set_filter=1&f%5B%5D=status_id&op%5Bstatus_id%5D=o&v%5Bstatus_id%5D%5B%5D=&c%5B%5D=id&c%5B%5D=project&c%5B%5D=tracker&c%5B%5D=status&c%5B%5D=priority&c%5B%5D=assigned_to&c%5B%5D=customer&c%5B%5D=subject&c%5B%5D=last_message&c%5B%5D=updated_on&c%5B%5D=created_on&c%5B%5D=total_spent_hours&c%5B%5D=estimated_hours&t%5B%5D=spent_hours&sort=updated_on%3Adesc%2Ccreated_on%2Cid%3Adesc&c%5B%5D=&encoding=ISO-8859-1" for 172.23.68.69 at 2019-07-15 14:11:38 -0400
Processing by IssuesController#index as CSV
Parameters: {"utf8"=>"✓", "set_filter"=>"1", "f"=>["status_id"], "op"=>{"status_id"=>"o"}, "v"=>{"status_id"=>[""]}, "c"=>["id", "project", "tracker", "status", "priority", "assigned_to", "customer", "subject", "last_message", "updated_on", "created_on", "total_spent_hours", "estimated_hours", ""], "t"=>["spent_hours"], "sort"=>"updated_on:desc,created_on,id:desc", "encoding"=>"ISO-8859-1", "project_id"=>"stw-ca"}
Current user: REDACTED (id=10)
Completed 500 Internal Server Error in 40ms (ActiveRecord: 12.4ms)

FrozenError (can't modify frozen String):

It happens every time even with different options selected

History

#1 Updated by Taylor Naungayan about 1 month ago

  • Status changed from New to Resolved

Issue was caused by RedmineUP Helpdesk Plugin

#2 Updated by Marius BALTEANU about 1 month ago

  • Status changed from Resolved to Closed

Taylor Naungayan wrote:

Issue was caused by RedmineUP Helpdesk Plugin

Thanks for your feedback.

Also available in: Atom PDF