Defect #3190

Custom field won't be removed if you changed the tracker to a none-custom-field tracker

Added by Minjie Zhu over 8 years ago. Updated over 8 years ago.

Status:ClosedStart date:2009-04-16
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Custom fields
Target version:0.8.4
Resolution:Fixed Affected version:

Description

Confirmed with Redmine Ver: r2670

  1. create a custom field
  2. create a tracker that uses the custom field
  3. create a new issue using the tracker and enter some value into the custom field
  4. when the issue is shown click on Move
  5. Move the issue to another tracker without the custom field.
  6. Show the issue and the costom field still exists although the tracker doesn't contain the costom field.

I have to remove the custom field from the tracker which dosen't contain it by editing the Database directly.

I think if the tracker of issure is changed, the custom field which is not defined for the tracker should be removed.

Thank you for reading.

Associated revisions

Revision 2724
Added by Jean-Philippe Lang over 8 years ago

Fixes consistency of custom fields display on the issue detail view (#3190).

History

#1 Updated by Jean-Philippe Lang over 8 years ago

  • Status changed from New to Resolved
  • Target version set to 0.8.4
  • Resolution set to Fixed

This is fixed in r2724.

#2 Updated by Minjie Zhu over 8 years ago

Jean-Philippe Lang wrote:

This is fixed in r2724.

I confirmed the revision and it works well!

And I found that this revision just changed the view, but not the data in DB. Because if I return the tracker to the former, the custom field shows the old data.

Maybe it would be nice to clear the custom field of the ticket when the tracker is changed.

But now it maybe good enough. So thank you so much for your help :)

#3 Updated by Jean-Philippe Lang over 8 years ago

  • Status changed from Resolved to Closed

Merged in 0.8-stable in r2746.

Also available in: Atom PDF