Defect #3699

Problem with sqlquery in journal.rb

Added by Łukasz Żbikowski over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:2009-07-31
Priority:NormalDue date:
Assignee:Eric Davis% Done:

70%

Category:DatabaseEstimated time:1.00 hour
Target version:-
Resolution:Wont fix Affected version:0.8.4

Description

I noticed that problem on IRC channel... then created that solution.
In Oracle DB RM throws SQL error.

It's caused by
"#{Journal.table_name}.notes <> ''"

In Oracle DB RoR text is translated to CLOB...
Unfortunately Oracle CLOB cannot be compared with string like that...

solution is:
length(#{Journal.table_name}.notes)>0

tested with PgSQL.
Should also work with other DB.

My diff (RM 8.4) in the attachment

journal.rb.diff Magnifier - journal.rb diff (fixed for ORACLE) (1.14 KB) Łukasz Żbikowski, 2009-07-31 00:23

History

#1 Updated by Ben Wagaman over 9 years ago

+1

I have the same issue with Oracle. After applying this patch, the issue is fixed in Oracle for me as well. Thank you.

#2 Updated by Jean-Philippe Lang over 9 years ago

  • Status changed from New to Closed
  • Resolution set to Wont fix

Oracle is not supported. Sorry.

Also available in: Atom PDF