Defect #3755

Viewing an issue dies if the description contains two adjacent equals signs

Added by Nick Read about 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:2009-08-19
Priority:HighDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Cant reproduce Affected version:

Description

I don't want to actually put the bad text into this issue in case it breaks it, but it is two adjacent equals signs, as in = followed immediately by another = with no whitespace. This happens every now and then on our Java project that uses Freemarker, which 'helpfully' outputs nice error messages that contains this sequence of characters. The only way we can fix this is to change the issue description in the database to remove them.

Looking at the stack trace below, it can be seen that it's not necessarily restricted to issue descriptions, but to anything that is passed into 'textilizable'. This is a problem in the current SVN trunk, and probably all existing releases too.

/usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/fcgi_handler.rb:158:in `exit'
    /usr/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/fcgi_handler.rb:158:in `exit_now_handler'
    /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `to_proc'
    lib/redcloth3.rb:983:in `call'
    lib/redcloth3.rb:983:in `gsub!'
    lib/redcloth3.rb:983:in `no_textile'
    lib/redcloth3.rb:297:in `to_html'
    lib/redmine/wiki_formatting/textile/formatter.rb:39:in `to_html'
    lib/redmine/wiki_formatting.rb:47:in `to_html'
    app/helpers/application_helper.rb:363:in `textilizable'
    app/views/issues/show.rhtml:59
    /usr/lib/ruby/gems/1.8/gems/actionpack-2.2.2/lib/action_view/renderable.rb:39:in `send'
    /usr/lib/ruby/gems/1.8/gems/actionpack-2.2.2/lib/action_view/renderable.rb:39:in `render'
    /usr/lib/ruby/gems/1.8/gems/actionpack-2.2.2/lib/action_view/template.rb:73:in `render_template'
    /usr/lib/ruby/gems/1.8/gems/actionpack-2.2.2/lib/action_view/base.rb:256:in `render'
    /usr/lib/ruby/gems/1.8/gems/actionpack-2.2.2/lib/action_view/base.rb:367:in `_render_with_layout'
    /usr/lib/ruby/gems/1.8/gems/actionpack-2.2.2/lib/action_view/base.rb:254:in `render'
    /usr/lib/ruby/gems/1.8/gems/actionpack-2.2.2/lib/action_controller/base.rb:1174:in `render_for_file'
    /usr/lib/ruby/gems/1.8/gems/actionpack-2.2.2/lib/action_controller/base.rb:899:in `render_without_benchmark'
    /usr/lib/ruby/gems/1.8/gems/actionpack-2.2.2/lib/action_controller/benchmarking.rb:51:in `render'
    /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/core_ext/benchmark.rb:8:in `realtime'
    /usr/lib/ruby/gems/1.8/gems/actionpack-2.2.2/lib/action_controller/benchmarking.rb:51:in `render'
    app/controllers/issues_controller.rb:119:in `show'
    ...

History

#1 Updated by Nick Read about 5 years ago

I've made a sample of the text causing the problem at http://www.pastebin.ca/1534517

#2 Updated by Eric Davis almost 5 years ago

Works fine on the demo (r2784) and on the preview here. Is there any more information you can provide?

http://demo.redmine.org/issues/4587

#3 Updated by Jean-Philippe Lang almost 5 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce

#4 Updated by Nick Read almost 5 years ago

Sorry for not responding 2 months ago Eric. I can confirm that this appears to be fixed in the current SVN trunk. Cheers!

Also available in: Atom PDF