Defect #3981

Scramble passwords in database table "Repositories"

Added by zhang huitao about 8 years ago. Updated about 8 years ago.

Status:ClosedStart date:2008-10-15
Priority:HighDue date:
Assignee:-% Done:

30%

Category:SCM
Target version:-
Resolution:Duplicate Affected version:

Description

If I do

SELECT r.login, r.password, r.url FROM repositories r

I can see all passwords and repository resources, though I mustn't to. Better to scramble passwords.


Related issues

Duplicates Redmine - Feature #2034: Scramble passwords in database table "Repositories" Closed 2008-10-15

History

#1 Updated by Nick Read about 8 years ago

  • Status changed from New to Resolved
  • Assignee deleted (Azamat Hackimov)

This is a duplicate of #2034

#2 Updated by Jean-Philippe Lang about 8 years ago

  • Status changed from Resolved to Closed
  • Resolution changed from Fixed to Duplicate

Also available in: Atom PDF