Defect #4530

Can't delete ldap when users count is zero in 0.9-stable

Added by Sheng Wang almost 8 years ago. Updated almost 8 years ago.

Status:ClosedStart date:2010-01-07
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:LDAP
Target version:0.9.0
Resolution:Fixed Affected version:0.8.7

Description

Specific URL:

http://foo.bar/auth_sources/list

Related Code(app/views/auth_sources/list.rhtml):
<%= link_to l(:button_delete), { :action => 'destroy', :id => source },
                                                        :confirm => l(:text_are_you_sure),
                                                        :class => 'icon icon-del',
                                                        :disabled => source.users.any? %>

The link_to method does not contain :disabled options.
I think this problem is caused by code change(button_to have been replaced by link_to).

Associated revisions

Revision 3282
Added by Jean-Philippe Lang almost 8 years ago

Fixed: 'Delete' link on LDAP list has no effect (#4530).

History

#1 Updated by Jean-Philippe Lang almost 8 years ago

  • Status changed from New to Resolved
  • Target version set to 0.9.0
  • Affected version (unused) set to 0.8.7
  • Resolution set to Fixed
  • Affected version set to 0.8.7

Fixed in r3282.

#2 Updated by Jean-Philippe Lang almost 8 years ago

  • Status changed from Resolved to Closed

Merged in 0.9-stable in r3287.

Also available in: Atom PDF