Defect #4899

Redmine fails to list files for darcs repository

Added by James Hiebert over 7 years ago. Updated almost 7 years ago.

Status:ClosedStart date:2010-02-22
Priority:NormalDue date:
Assignee:Toshi MARUYAMA% Done:

0%

Category:SCM
Target version:1.1.1
Resolution:Fixed Affected version:0.9.2

Description

My organization uses darcs for all of our revision control and development, so I'm trying to get darcs set up as a repository in redmine. I'm having a couple of problems. I've set up a project and added a darcs repository to the project (using the local path to the repo). The first problem is that when I click on the "Repository" tab under the project, I get an error saying "The entry or revision was not found in the repository." The debug logs then show an internal server error as shown in the attached log file.

The activity tab does show all of my patches. But if I click on one of the patches and then click on one of the files that is in the patch set, I get the same error as above. Any ideas what the problem is?

I am using redmine-0.9.2 (from Gentoo linux's ebuild) as well as:
Linux version 2.6.31-gentoo-r6

Ruby and rails:
dev-lang/ruby-1.8.7_p249
Rails 2.3.5
dev-db/sqlite-3.6.22-r2
dev-ruby/sqlite3-ruby-1.2.4

Lighttpd:
www-servers/lighttpd-1.4.25-r1

FastCGI:
dev-libs/fcgi-2.4.0-r2
dev-ruby/ruby-fcgi-0.8.7
www-servers/spawn-fcgi-1.6.3

Darcs:
dev-util/darcs-2.2.1

redmine.darcs.error.txt Magnifier (14.2 KB) James Hiebert, 2010-02-22 21:59


Related issues

Related to Redmine - Defect #7415: Darcs adapter recognizes new files as modified files abov... Closed 2011-01-22

Associated revisions

Revision 4744
Added by Toshi MARUYAMA almost 7 years ago

scm: darcs: switch '.' or @url at entries() in darcs version (#4899).

History

#1 Updated by Jean-Philippe Lang over 7 years ago

  • Category set to SCM

#2 Updated by James Hiebert over 7 years ago

Would someone who works on the SCM modules please take a look at this forum:

http://www.redmine.org/boards/2/topics/11517

and see if we're on the right track?

#3 Updated by Toshi MARUYAMA almost 7 years ago

  • Status changed from New to 7
  • Assignee set to Toshi MARUYAMA

#4 Updated by Toshi MARUYAMA almost 7 years ago

I committed r4744 for this issue.
But, Darcs above 2.4 has new issue.
Please see #7415.

#5 Updated by Toshi MARUYAMA almost 7 years ago

  • Status changed from 7 to Closed
  • Target version set to 1.1.1
  • Resolution set to Fixed

I committed r4747 for 1.1.1.

Also available in: Atom PDF