Feature #4969

issue creation by email fails when on-the-fly user creation fails

Added by Jérôme Bousquié almost 8 years ago. Updated about 6 years ago.

Status:ClosedStart date:2010-03-02
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Email receiving
Target version:-
Resolution:Duplicate

Description

When issue creation is set up for creating unknown user on the fly, these users are created and identified by their email.
If email length exceeds 30 characters, the user creation isn't allowed and the issue isn't accepted. The user doesn't the reason.

Maybe would it be possible to create some valid identifier (salt+timestamp e.g) in this case for this user and still store his email in the email field, so his submitted issue would be registred ?

More generally, is it possible to prevent issue rejections because of user creation problems (or simply prevent automatic user creation rejections) ?

Thanks

--
Jérôme Bousquié


Related issues

Related to Redmine - Defect #7717: MailHandler user creation for unknown_user impossible due... Closed 2011-02-25

History

#1 Updated by Jean-Philippe Lang about 6 years ago

  • Category set to Email receiving
  • Status changed from New to Closed
  • Resolution set to Duplicate

Same as #7717, fixed in r7952.

Also available in: Atom PDF