Defect #54

IE7 cyrillic not displayed correctly

Added by Nikolay Solakov over 10 years ago. Updated over 10 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution: Affected version:

Description

This is the first part of the Bug #10499. Maybe Jean-Philippe did not understand I mean it as a bug.
The cyrillic characters are not displayed correctly, it's like hex edit :)
There is a screenshot attached.
The page encoding is set to Unicode (UTF-8). I'm using the native
windows language bar.

Thanks, Nikolay

cyrillic_chars.JPG (117 KB) Nikolay Solakov, 2008-02-03 10:50

issue_edit_bg.gif (31.7 KB) Nikolay Solakov, 2008-02-03 10:50

History

#1 Updated by Nikolay Solakov over 10 years ago

I'm sorry.
It's not redMine related problem. I tried other sites with
utf8 and typing was the same. IE7 - s*cks :)

Thanks,
Nikolay

#2 Updated by Jean-Philippe Lang over 10 years ago

Oh, I copied the cyrillic text indeed. I don't even know how
I could type it :-)

At this time, I have no idea about the reason of this problem.
Maybe someone else has a clue ?

#3 Updated by Nikolay Solakov over 10 years ago

Jean-Philippe, did you paste the cyrillic text with the
clipboard or you typed it? With pasteing it's ok, but with
typing I still got the problem :(
I created the database like this: CREATE DATABASE `redmine`
CHARACTER SET utf8 COLLATE utf8_general_ci;
Added the encoding: utf8 in the database.yml file and
migrated the base. The truncation of 'Техническа
документация' is gone now, but if I try to type some
text in
cyrillic I got the same strange characters.

Thanks,
Nikolay

#4 Updated by Jean-Philippe Lang over 10 years ago

With settings explained here:
http://rubyforge.org/tracker/index.php?func=detail&aid=10469x%x%
amp;group_id=1850&atid=7160
it works fine. See attached screenshot

Also available in: Atom PDF