Feature #5732

cannot copy/move subtask from one parent issue to another

Added by Igor Balk over 9 years ago. Updated almost 8 years ago.

Status:ReopenedStart date:2010-06-22
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UI
Target version:-
Resolution:Invalid

Description

cannot change (move?) subtask from one parent issue to another. Should also be able to un-subtask an issue (make top level)

http://www.redmine.org/wiki/redmine/UXTeamMeeting1

Screenshot.png (70.6 KB) Yuki Kita, 2010-06-22 22:18

History

#1 Updated by Yuki Kita over 9 years ago

It is possible to move subtask from one parent to another in trunk.
you have to "Change properties(More)" to do it.
But I think it difficult for users to find this way.
So the UI should be changed.

#2 Updated by Felix Schäfer over 9 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Invalid

#3 Updated by Ladislav Nesnera over 9 years ago

My experience is the same - it's a difficult to find out how to change parent task. I wasn't able to do it until I found this report.. ;?)
What about to allow select existing task not only create new by action "Add" in "Subtasks" section?

#4 Updated by Hans Bangkok over 8 years ago

  • Status changed from Closed to Reopened

I didn't want to create a new issue for this, since there might be a similar report this could be linked to - it's so difficult to search for the keyword "Duplicate"!

First of all, a minor issue, but the above comment on improving the UI is very valid - having to get the parent issue number and manually enter it into the parent field in order to move an issue to be a sub-task works, but isn't exactly elegant 8-)

More critically, I've found when doing a "Duplicate" of a sub-task, it does not inherit the link to the parent - I would think that would be the intended behaviour of Duplicate. (PS I couldn't find anything in the docs explaining the distinction between duplicate and copy?)

If this is a new report of the latter issue, please let me know and I'll create a new issue (or of course you can file it yourself if you prefer 8-)

#5 Updated by Cornell Wright over 8 years ago

+1

I just spent a few hours trying to figure out how to change the parent of an issue and preserve all the other links. The current method of having to click "More" is very non-intuitive.

#6 Updated by Sven Müller about 8 years ago

It would be greate to change/set parent for a set of issues in one action.

By selection issues in the issue list and changing parent by the right-click-menu.

#7 Updated by K. Scott Tripp almost 8 years ago

+1

I think that putting the option in the "move" menu would work well.

Also available in: Atom PDF