Feature #8392

Grant access to particular Wiki page

Added by Kamil . over 6 years ago. Updated over 1 year ago.

Status:ClosedStart date:2011-05-18
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Permissions and roles
Target version:-
Resolution:Duplicate

Description

Some of the Wiki pages (like these containing logins/passwords to the third party services or other confidental information) should not be viewed by all of the project members!

It has to be possible to grant/deny access to that particular Wiki pages.


Related issues

Duplicates Redmine - Feature #2636: Feature Request: Wiki ACLs (Access control for individual... New 2009-01-31

History

#1 Updated by Dmitry Salashnik over 6 years ago

+1

#2 Updated by Aleksandra Wozniak over 6 years ago

+1

#3 Updated by Andrzej Kojder over 6 years ago

+1

#4 Updated by Anoop L over 6 years ago

+1

#5 Updated by Adam Hepner over 6 years ago

+1

#6 Updated by Jeffrey Jones over 6 years ago

Would you guys expect to be able to do something like:

Page A can only be viewed by users A B C?
Page B can only be views by users D F G and Group Z?

Or is a simple "Page protected" flag per page plus a "view protected page" permission good enough?

#7 Updated by Kamil . over 6 years ago

The second option is good for the beginning because it seems to be easy to implement and it's better than nothing.
Ideal to have them both.

#8 Updated by Daniel Schaarschmidt over 6 years ago

+1
The secound option should be good enough - it could be similar to the new private issues feature.

The first option sounds really good - but like Kamil I'm not sure this is as easy to implement as option 2.
IMHO it would require a complete change of the permission system to really fit in. Right now I'm not aware of any Redmine-Feature that maintains a seperate permission list per object - although under some circumstances it would be great to have that.

#9 Updated by Naveen Prabhu almost 6 years ago

+1

#10 Updated by Tomas Chmiel about 5 years ago

Are there any news on this feature?

#11 Updated by dale woolridge about 5 years ago

there is the redmine_wiki_permissions plugin that can do this. i've recently put in a pull request so it works properly with 1.4. i haven't tried with 2.0. it shouldn't conflict with other plugins anymore.

#12 Updated by Alexander Pilipenko over 3 years ago

+1
redmine_wiki_permissions plugin does not work with redmine >2.0

#13 Updated by Hans Artmann over 3 years ago

Tried to install redmine_wiki_permissions in 2.5 with rails 3.2 and came as far as

  • install with _rails install
  • move the redmine_wiki_permissions folder from vendor/plugins to plugins
  • add dispatcher to Gemfile

Now I'm getting

redmine_wiki_permissions/init.rb:7:in `<top (required)>': undefined method `to_prepare' for Dispatcher:Module (NoMethodError)

on startup. I guess the dispatcher gem isn't 3.2 compatible

Any ideas? I'd really have the wiki permissions back now that my upgrade from redmine 1.0 to 2.5 has worked (basically installing rvm, doing a fresh redmine install and migrating the database).

#14 Updated by Anh Le Giang over 1 year ago

+1

#15 Updated by Toshi MARUYAMA over 1 year ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #2636.

#16 Updated by Toshi MARUYAMA over 1 year ago

  • Duplicates Feature #2636: Feature Request: Wiki ACLs (Access control for individual pages) added

Also available in: Atom PDF