Defect #8753

PDF export for Hebrew is reversed

Added by Orgad Shaneh about 7 years ago. Updated almost 4 years ago.

Status:ClosedStart date:2010-07-15
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:PDF export
Target version:2.6.0
Resolution:Fixed Affected version:

Description

PDF export of an issue is displayed from left to right (e.g. שלום is displayed as םולש)


Related issues

Related to Redmine - Defect #10681: Export to Persian PDF problem Closed
Related to Redmine - Feature #13317: Pluggable PDF export engine New

History

#1 Updated by Jonathan M almost 7 years ago

I can confirm that this is still an issue in 1.3.0

#2 Updated by Jun NAITOH almost 7 years ago

Redmine is useing RFPDF (TCPDF) library.
But RFPDF is not supporting RTL (Right-To-LeftRTF) now.
I think that RFPDF library needs to add RTL function, and if I am possible, I would like to challenge it.

#3 Updated by Toshi MARUYAMA almost 7 years ago

  • Resolution deleted (Duplicate)

#4 Updated by Orgad Shaneh almost 7 years ago

Duplicate of...?

#5 Updated by Orgad Shaneh almost 7 years ago

Orgad Shaneh wrote:

Duplicate of...?

Got it. It was marked as duplicate by mistake, and now you deleted it. Ignore my comment...

#6 Updated by Genadi Saltikov about 6 years ago

Any update on this issue guys?
I tried to search for RFPDF in relation to RTL or right to left on google, but did not get anything relevant :(

Are there any alternative libraries, could you consider switching? Redmine is incomplete without support for RTL languages - unfortunately I am not the only user :(

#7 Updated by William Roush about 6 years ago

The RFPDF author migrated his apps to Prawn, probably a good option.

https://github.com/prawnpdf/prawn

#8 Updated by Jun NAITOH about 6 years ago

Any update on this issue guys?

I am still challengeing.
I think it possible to support RTL in RFPDF library.

#9 Updated by Ebrahim Mohammadi over 4 years ago

Any news on support of RTL in RFPDF and Redmine PDF export?

#10 Updated by Toshi MARUYAMA over 4 years ago

#11 Updated by Toshi MARUYAMA over 4 years ago

Ebrahim Mohammadi wrote:

Any news on support of RTL in RFPDF and Redmine PDF export?

See #13317#note-6.

#12 Updated by Toshi MARUYAMA almost 4 years ago

  • Status changed from New to Closed
  • Target version set to 2.6.0
  • Resolution set to Fixed

Fixed by #17570.

Also available in: Atom PDF