Redmine 2.4.0 and 2.3.4 released

Added by Jean-Philippe Lang 11 months ago

Redmine 2.4.0 adds role-based issue custom field visibility and is available for download. You can review the list of the all the features and fixes for this version in the Changelog.

Redmine 2.3.4 is a maintenance release for 2.3.x users.


Comments

Added by Terence Mill 11 months ago

Tx a lot!
Are there any potential api changes on rest or plugin api which could harm plugins stability?

Added by Scott Macpherson 11 months ago

Awesome. I'm looking forward to getting 2.4.0 up-and-running at work tomorrow. Keep up the brilliant work!

Added by Deoren Moor 11 months ago

Thanks!

Added by Jean-Philippe Lang 11 months ago

Are there any potential api changes on rest or plugin api which could harm plugins stability?

The REST API got a few additions but stays compatible. The plugin API did not change but plugins can do many things like overriding views, methods... and compatibility cannot be guaranteed.

Added by Felix Prüll 11 months ago

Hello,

thanks a lot for the update. Can anyone tell me, why there are two different versions? whats the reason? i want to upgrade my 2.2.4 - which version should i take?

Thanks and Regards
Felix

Added by Marco Descher 11 months ago

Hy Jean-Philippe, thanks a lot for the release!

There however seems to be some problems with the REST API, I documented them in #15427 and #15424!

All the best,
Marco

Added by Jean-Philippe Lang 11 months ago

There however seems to be some problems with the REST API, I documented them in #15427 and #15424!

Redmine 2.4.1 is released and fixes the issues with the REST API found in 2.4.0. Thanks for reporting this.

Added by Scott Macpherson 11 months ago

Felix Prüll wrote:

thanks a lot for the update. Can anyone tell me, why there are two different versions? whats the reason? i want to upgrade my 2.2.4 - which version should i take?

There's a difference in the Ruby version supported by 2.3.x and 2.4.x, but since you're back on 2.2.x you should probably just upgrade all the way to 2.4.1.

Added by CM Gui 10 months ago

On [[http://www.redmine.org/projects/redmine/wiki/RedmineInstall]] and in the INSTALL file of 2.4.x, the Ruby versions are 1.8.7, 1.9.2, 1.9.3 or 2.0.0. These are the same as Redmine 2.3.x. So what is the "difference in the Ruby version supported by 2.3.x and 2.4.x" ? Thank you.