installingmysqlgem.txt

Peter Pan, 2012-07-06 19:20

Download (5.19 KB)

 
1
root@svn321://etc# gem install mysql --no-ri --no-rdoc
2
Building native extensions.  This could take a while...
3
ERROR:  Error installing mysql:
4
        ERROR: Failed to build gem native extension.
5

    
6
/usr/bin/ruby1.8 extconf.rb
7
checking for mysql_query() in -lmysqlclient... no
8
checking for main() in -lm... yes
9
checking for mysql_query() in -lmysqlclient... no
10
checking for main() in -lz... no
11
checking for mysql_query() in -lmysqlclient... no
12
checking for main() in -lsocket... no
13
checking for mysql_query() in -lmysqlclient... no
14
checking for main() in -lnsl... yes
15
checking for mysql_query() in -lmysqlclient... no
16
checking for main() in -lmygcc... no
17
checking for mysql_query() in -lmysqlclient... no
18
*** extconf.rb failed ***
19
Could not create Makefile due to some reason, probably lack of
20
necessary libraries and/or headers.  Check the mkmf.log file for more
21
details.  You may need configuration options.
22

    
23
Provided configuration options:
24
        --with-opt-dir
25
        --without-opt-dir
26
        --with-opt-include
27
        --without-opt-include=${opt-dir}/include
28
        --with-opt-lib
29
        --without-opt-lib=${opt-dir}/lib
30
        --with-make-prog
31
        --without-make-prog
32
        --srcdir=.
33
        --curdir
34
        --ruby=/usr/bin/ruby1.8
35
        --with-mysql-config
36
        --without-mysql-config
37
        --with-mysql-dir
38
        --without-mysql-dir
39
        --with-mysql-include
40
        --without-mysql-include=${mysql-dir}/include
41
        --with-mysql-lib
42
        --without-mysql-lib=${mysql-dir}/lib
43
        --with-mysqlclientlib
44
        --without-mysqlclientlib
45
        --with-mlib
46
        --without-mlib
47
        --with-mysqlclientlib
48
        --without-mysqlclientlib
49
        --with-zlib
50
        --without-zlib
51
        --with-mysqlclientlib
52
        --without-mysqlclientlib
53
        --with-socketlib
54
        --without-socketlib
55
        --with-mysqlclientlib
56
        --without-mysqlclientlib
57
        --with-nsllib
58
        --without-nsllib
59
        --with-mysqlclientlib
60
        --without-mysqlclientlib
61
        --with-mygcclib
62
        --without-mygcclib
63
        --with-mysqlclientlib
64
        --without-mysqlclientlib
65

    
66

    
67
Gem files will remain installed in /var/lib/gems/1.8/gems/mysql-2.8.1 for inspection.
68
Results logged to /var/lib/gems/1.8/gems/mysql-2.8.1/ext/mysql_api/gem_make.out
69
root@svn321://etc# apt-get install build-essential subversion libmysqlclient15-dev libdigest-sha1-perl libgemplugin-ruby libgemplugin-ruby1.8 libruby-extras libruby1.8-extras rails rake ruby rubygems rubygems1.8 ruby1.8-dev libopenssl-ruby1.8
70
Paketlisten werden gelesen... Fertig
71
Abh?ngigkeitsbaum wird aufgebaut
72
Status-Informationen einlesen... Fertig
73
build-essential ist schon die neueste Version.
74
subversion ist schon die neueste Version.
75
Hinweis: libmysqlclient-dev wird an Stelle von libmysqlclient15-dev gew?hlt
76
libdigest-sha1-perl ist schon die neueste Version.
77
libgemplugin-ruby ist schon die neueste Version.
78
libgemplugin-ruby1.8 ist schon die neueste Version.
79
libgemplugin-ruby1.8 wurde als manuell installiert festgelegt.
80
libruby-extras ist schon die neueste Version.
81
libruby1.8-extras ist schon die neueste Version.
82
libruby1.8-extras wurde als manuell installiert festgelegt.
83
rails ist schon die neueste Version.
84
rails wurde als manuell installiert festgelegt.
85
rake ist schon die neueste Version.
86
rake wurde als manuell installiert festgelegt.
87
ruby ist schon die neueste Version.
88
ruby wurde als manuell installiert festgelegt.
89
rubygems ist schon die neueste Version.
90
rubygems wurde als manuell installiert festgelegt.
91
rubygems1.8 ist schon die neueste Version.
92
rubygems1.8 wurde als manuell installiert festgelegt.
93
ruby1.8-dev ist schon die neueste Version.
94
libopenssl-ruby1.8 ist schon die neueste Version.
95
libopenssl-ruby1.8 wurde als manuell installiert festgelegt.
96
Die folgenden zus?tzlichen Pakete werden installiert:
97
  libmysqlclient-dev zlib1g-dev
98
Die folgenden NEUEN Pakete werden installiert:
99
  libmysqlclient-dev zlib1g-dev
100
0 aktualisiert, 2 neu installiert, 0 zu entfernen und 1 nicht aktualisiert.
101
Es m?ssen 3.243kB an Archiven heruntergeladen werden.
102
Nach dieser Operation werden 8.544kB Plattenplatz zus?tzlich benutzt.
103
M?chten Sie fortfahren [J/n]? j
104
Hole:1 http://de.archive.ubuntu.com/ubuntu/ lucid/main zlib1g-dev 1:1.2.3.3.dfsg-15ubuntu1 [162kB]
105
Hole:2 http://de.archive.ubuntu.com/ubuntu/ lucid-updates/main libmysqlclient-dev 5.1.63-0ubuntu0.10.04.1 [3.081kB]
106
Es wurden 3.243kB in 0s geholt (6.456kB/s)
107
W?hle vormals abgew?hltes Paket zlib1g-dev.
108
(Lese Datenbank ... 90536 Dateien und Verzeichnisse sind derzeit installiert.)
109
Entpacke zlib1g-dev (aus .../zlib1g-dev_1%3a1.2.3.3.dfsg-15ubuntu1_i386.deb) ...
110
W?hle vormals abgew?hltes Paket libmysqlclient-dev.
111
Entpacke libmysqlclient-dev (aus .../libmysqlclient-dev_5.1.63-0ubuntu0.10.04.1_i386.deb) ...
112
Verarbeite Trigger f?r man-db ...
113
Richte zlib1g-dev ein (1:1.2.3.3.dfsg-15ubuntu1) ...
114
Richte libmysqlclient-dev ein (5.1.63-0ubuntu0.10.04.1) ...
115

    
116
Verarbeite Trigger f?r libc-bin ...
117
ldconfig deferred processing now taking place
118
root@svn321://etc# gem install mysql --no-ri --no-rdoc
119
Building native extensions.  This could take a while...
120
Successfully installed mysql-2.8.1
121
1 gem installed
122
root@svn321://etc#