Ubuntu 10.04 LTS Redmine 1.1.3 to 1.2.0 Upgrade ( set_cookie_header ) fix

Added by John Reynolds almost 9 years ago

So I ran into some problems moving from 1.1.3 to 1.2.0 on a typical Ubuntu 10.04 install.
Thought this might help someone. Here's what I did - this worked for me:

You have to get the versions up to date first, and to the specific versions:
  • sudo gem install rails -v=2.3.11
  • sudo gem install rack -v=1.1.1
Then, you need to uninstall the older versions. In each case, I removed the 2.3.5 versions only unless otherwise listed. In each case, I want to just be left with one version.
  • sudo gem uninstall actionmailer
  • sudo gem uninstall actionrecord
  • sudo gem uninstall activesupport
  • sudo gem uninstall activeresource
  • sudo gem uninstall actionpack
  • sudo gem uninstall rails
  • sudo gem uninstall rack (all versions but 1.1.1)
  • sudo gem uninstall passenger (say Y for all the other stuff it will complain about)
  • sudo gem install passenger (it will probably install 3.0.7)

Now run the passenger apache2 module install:
sudo /var/lib/gems/1.8/gems/passenger-3.0.7/bin/passenger-install-apache2-module

In my case, it found some dependencies missing. Basically just follow the instructions! In my case, I had to install libcurl4-openssl-dev through apt-get.

If you had to install other stuff, just run it again until it installs successfully:
sudo /var/lib/gems/1.8/gems/passenger-3.0.7/bin/passenger-install-apache2-module

It will tell you at the end about how to modify your files. Basically:

sudo vi /etc/apache2/mods-enabled/passenger.conf
and edit the path per the info in the install. Basically mine changed from .../passenger-2.2.4 to .../passenger-3.0.7

sudo vi /etc/apache2/mods-enabled/passenger.load
and edit the path per the info in the install. Same thing - just the path.

Start Apache2 again, and things were perfect.

Hope this might help.