Redmine Bitnami on Google Cloud Platform - Phusion Passenger fails

Added by brusli bravo over 2 years ago

Hi Team,

This is a throw away so my mates don't think I'm a total Muppet....

I'm looking to use Redmine for a small construction project with 3 to 10 members for issue tracking, small wiki and linking to data folders on our local server. I have recently been working on setting up a redmine 4.1.0-0 instance on GCP through Bitnami as I'm a total noob when it comes to all of this. I got it up and running and have not been able to get it to load the web interface after a reboot. seems like i have a problem with Phusion Passenger. "Web application could not be started by the Phusion Passenger application server".

I have tried reinstalling the instance many times to see if its the installation causing issues however its clearly not. Working through some notes on the net stating that its some issue with --nginx or something way beyond me.

So my questions;

Is Bitnami the problem? I tried the google instance however it was quite a bit old 3.3.x and I wasn't confident I could upgrade it while live and not loose my data

Is there a better way to get this going? I don't want to upload my 600+ issues from my spreadsheet for it to fall over one day while working on the server.

Should I just witch to matis and install all the plugins to make it what I need?

Thanks for your input!