synology docker redmine keeps restarting

Added by James L 4 months ago

Description of the errors:
I have been succesful in installing the redmine and postgres db images to containers from the CLI/SSH interface.

After some weeks of testing it did only work with named volumes and not using paths which I prefer.

if I install the redmine docker image to a container and use folders it keeps restarting immediately.

if I install with volumes for both postgres and redmine it works for many hours, but if I then stop and start redmine the same problem comes back with restarting.

The same happens on BOTH of my synology machines, one DS918+ and DS1517+

I have on a differnt and much bigger server been able to install with the same procedure as on my synology servers. I would like to have it on the synology.

What is the reason for this restart?
Does anyone else have the same issue?

Docker version: latest for synology

Code and parameters:
I have used the following code to create and run the dockers

$ docker network create --driver bridge redmine_network

$ docker volume create postgres-data

$ docker volume create redmine-data

$ docker container run -d --name postgres --network redmine_network -v postgres-data:/var/lib/postgresql/data --restart always -e POSTGRES_PASSWORD='password' -e POSTGRES_DB='redmine' postgres:latest

$ docker container run -d --name redmine --network redmine_network --restart always -p 3434:3000 --restart always -v redmine-data:/usr/src/redmine/files -e REDMINE_DB_POSTGRES='postgres' -e REDMINE_DB_DATABASE='redmine' -e REDMINE_DB_PASSWORD='password' redmine:latest

I have also tried with server paths but it does not work either.

I have tried to solve it by opening the firewall for the docker also, but the result is the same.

The docker start working until I restart it. Then it keeps restarting all the time.

Alternative server:
I have used the above code on a "big" ubuntu server and that works fine without restaring.