Project

General

Profile

Trying to build a mesh using Batman-adv and Raspberry PI

Added by Gonçalo Mendes 11 months ago

I'm trying to create an ad hoc mesh using raspberry pi 3 model b 1.2, OpenWRT and Batman-ADV
(Ad hoc because rasp doesn't support 802.11s)
Now I'm using only 2 and trying to connect the only on L2 using batman-adv
I was following the Batman-adv. web site instructions and some videos
and i always reach the same result

After configurate one of the nodes, by executing "batctl if" should appear the interfaces I configurate earlier but doesn't appear, this is my current configurations:

/etc/config/network

config interface 'bat0'
option proto 'batadv'
  1. optional settings to override the defaults:
    option routing_algo 'BATMAN_IV'
    option aggregated_ogms 1
    option ap_isolation 0
    option bonding 0
    option fragmentation 1
    option gw_mode 'off'
    #option gw_bandwidth '10000/2000'
    #option gw_sel_class 20
    option log_level 0
    option orig_interval 1000
    option bridge_loop_avoidance 1
    option distributed_arp_table 1
    option multicast_mode 1
    option multicast_fanout 16
    option network_coding 0
    option hop_penalty 30
    option isolation_mark '0x00000000/0x00000000'

config interface 'bat0_hardif_mesh0'
option proto 'batadv_hardif'
option master 'bat0'
option mtu '1536'

/etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/soc/3f300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
option band '2g'
option htmode 'HT20'
option cell_density '0'
option channel '1'

config wifi-iface 'wmesh'
option device 'radio0'
option ifname 'mesh0'
option network 'bat0_hardif_mesh0'
option mesh_ttl '5'
option mcast_rate '24000'
option encryption 'none'
option mode 'adhoc'
option ssid 'my-mesh'

honestly i dont know whats wrong...