Redmine runs with WEBRick, but not with lighttpd

Added by Mitch Pirtle over 14 years ago

I have Debian Lenny x86_64 running redmine trunk, at least on port 3000. :-)

However when I try to fire up lighttpd I get the following:

2010-03-01 20:43:08: (log.c.75) server started 
2010-03-01 20:43:08: (mod_fastcgi.c.1047) the fastcgi-backend /usr/bin/ruby /var/www/
 failed to start: 
2010-03-01 20:43:08: (mod_fastcgi.c.1051) child exited with status 9 /usr/bin/ruby /var/www/ 
2010-03-01 20:43:08: (mod_fastcgi.c.1054) If you're trying to run PHP as a FastCGI backend, make sure you're using the FastCGI-enabled
You can find out if it is the right one by executing 'php -v' and it should display '(cgi-fcgi)' in the output, NOT '(cgi)' NOR '(cli)'.
For more information, check this is PHP on
 Gentoo, add 'fastcgi' to the USE flags. 
2010-03-01 20:43:08: (mod_fastcgi.c.1358) [ERROR]: spawning fcgi failed. 
2010-03-01 20:43:08: (server.c.908) Configuration of plugins failed. Going down.

My config for the vhost is as follows:

$HTTP["host"] =~ "^projects\. mitchitized\.com$" {
  server.document-root = "/var/www/" 
  server.follow-symlink = "enable" 
  alias.url = ()
  server.indexfiles = ( "dispatch.fcgi" )
  server.error-handler-404 = "/dispatch.fcgi" 

  fastcgi.server =  (
  ".fcgi" => (
    "redmine" => (
      "bin-path" => "/usr/bin/ruby /var/www/",
      "socket" => "/tmp/redmine.socket",
      "min-procs" => 1,
      "max-procs" => 4,
      "idle-timeout" => 120,
      "check-local" => "disable",
      "bin-environment" => ( "RAILS_ENV" => "production" ),

This is a mirrored setup from a Debian Lenny i386 machine. The one difference between them is that on the 64 bit machine I had to build ruby from source as the packages provided were too broken for me to figure out how to fix. I'm assuming everything is proper, since redmine does run perfectly fine as a ruby process; the only trouble I'm having is with fcgi and lighttpd integration.

So I'm assuming it's not ruby or redmine, but the fcgi setup with lighttpd. Thought I'd ask over here, as the redmine for the lighttpd project isn't letting me log in...

Is there a common cheatsheet for this? I've found several blog posts but they all use the debian packages that somehow work. Perhaps I'm getting bit by a x86_64 packaging bug?

Replies (1)

RE: Redmine runs with WEBRick, but not with lighttpd - Added by Mitch Pirtle over 14 years ago

Case solved, bin-path in lighttpd config was not correct for this system.

Making a mental note to check this next time around. Gah.