Added by Jordan Metzmeier over 14 years ago

I have been trying to get LDAP authentication working properly in Redmine. I am using MySQL 5 w/ RoR v 2.2. I have apache as front end and Mongrel Rails as the back end. The server is running on Ubuntu 7.10.

I put in my LDAP information and tested the connection successfully. I am thinking that issue might be with my base dn. I was hoping someone might be able to point out if something is wrong with my base DN as I am new to openLDAP. I have tried numerous combinations so far with now luck. Anyways here is what I have for my base DN:


I have tried without the "ou", with "ou", with and without "cn=admin" (and various other usernames). Here is an example of a user I am trying to authenticate via open LDAP shown in ldapsearch:

  1. adam, People, einstein.SSDLLC.local
    dn: uid=adam,ou=People,dc=einstein,dc=SSDLLC,dc=local
    uid: adam
    cn: Adam Smith
    objectClass: account
    objectClass: posixAccount
    objectClass: top
    objectClass: shadowAccount
    shadowMax: 99999
    shadowWarning: 7
    loginShell: /bin/sh
    uidNumber: 1001
    gidNumber: 1001
    homeDirectory: /home/adam
    gecos: Adam Smith

Is there anything noticably wrong with the base dn I have put in?

Thank you in advance for your input.