Application error Rails application failed to start properly

Added by Vianney Lecroart about 14 years ago

When trying to browse a specific file in the repo

http://dev.ryzom.com/repositories/changes/nel/nel/src/net/buf_server.cpp

I have this:

Application error
Rails application failed to start properly

I think it's the timeout of the "svn" exec call and I don't know how to change this timeout.

Any ideas?

Replies (5)

RE: Application error Rails application failed to start properly - Added by Thomas Lecavelier about 14 years ago

Look strange. Could you post the relative part of your log/production.log file, please? (there's no particular timeout set in the scm adaptor, AFAIK).

RE: Application error Rails application failed to start properly - Added by Vianney Lecroart about 14 years ago

There's nothing added when loading the page in the log/production.log

But I see a log in the fastcgi.crash.log

[16/Sep/2008:10:29:24 :: 24996] starting
[16/Sep/2008:10:29:46 :: 24996] asked to stop immediately

It seems to come from the "fastcgi.rb" but I have really no idea why everyworks fine except when we try to display some files from the repository.

RE: Application error Rails application failed to start properly - Added by Thomas Lecavelier about 14 years ago

I just hate fastcgi >_<

Sorry, I can't help with it: maybe you could have a look to your web server logs, I think they have fastcgi logs...

RE: Application error Rails application failed to start properly - Added by Vianney Lecroart about 14 years ago

Just for curiosity, what do you think I should use instead of fastcgi that working with apache

RE: Application error Rails application failed to start properly - Added by Thomas Lecavelier about 14 years ago

When having to deal with apache, I configure a simple reverse proxy toward thin (or mongrel) instances: easy to configure, easy to start, easy to monitor. A real pleasure to deal with :)

(1-5/5)