Help configuring redmine on ubuntu with exim4

Added by Lee Butler over 7 years ago

I have exim4 installed on my ubuntu system and told redmine to use the "sendmail" delivery method. Alas, no messages were being generated. I substituted a simple shell script for "sendmail" and learned that redmine is invoking sendmail with the "-t" option:

sendmail -i -t -f redmine@hostname user@host2

Looking at the exim4 documentation:

When Exim is receiving a locally-generated, non-SMTP message on its standard input, the "-t" option causes the recipients of the message to be obtained from the To:, Cc:, and Bcc: header lines in the message instead of from the command arguments. ... If the command has any arguments, they specify addresses to which the message is not to be delivered.

As a result, no mail is being delivered (the addressee is specified in the file and removed by being on the command line as well). I have two options:

  • Try to turn this behavior off in Exim (which seems to involve setting "extract_addresses_remove_arguments false" in a configuration file I have not yet found)
  • Get redmine to somehow not specify the addressee(s) on the command line, or drop the "-t" option on the command line it uses to invoke sendmail.

Any suggestions (aside from the "skip exim" obviousness) would be welcome.

Replies (1)

RE: Help configuring redmine on ubuntu with exim4 - Added by Jan Niggemann (redmine.org team member) over 7 years ago

Just a guess, but what happens if you chose smtp as your delivery method?

Another idea, from http://apidock.com/rails/ActionMailer/Base:

sendmail_settings - Allows you to override options for the :sendmail delivery method.
:location - The location of the sendmail executable. Defaults to /usr/sbin/sendmail.
:arguments - The command line arguments. Defaults to -i -t with -f sender@address added automatically before the message is sent.

I don't know if this works, give it a shot:

sendmail_settings = { 
  :location       => '/usr/sbin/sendmail', 
  :arguments      => '-i'
}

(1-1/1)