hostname was not match with the server certificate

Added by Alain JUPIN almost 8 years ago

Hi all,

In the Administration -> Settings page, when I try send send a test email. I've the following error message :
hostname was not match with the server certificate

This my config/configuration.yml

production:
  email_delivery:
    delivery_method: :smtp
    smtp_settings:
      address: "localhost" 
      port: 25
      enable_starttls_auto: false
      openssl_verify_mode: 'none'

I've also tried the following parameters but doesn't solve my issue.

tls: false
domain: "localhost.localdomain" 
authentication: :none

When I do any modification on the redmine config files, I restart redmine by typing:
service apache2 restart
(redmine is running by apache2 and mod_passenger on a Debian Squeeze up to date)

The mail server is run by postfix on the same machine, but it doesn't receive anything (when reading the mail logs)

Environment:
  Redmine version                          2.1.5.stable
  Ruby version                             1.8.7 (x86_64-linux)
  Rails version                            3.2.8
  Environment                              production
  Database adapter                         MySQL
Redmine plugins:
  no plugin installed

Thanks a lot for your help

Replies (8)

RE: hostname was not match with the server certificate - Added by Jan Niggemann (redmine.org team member) almost 8 years ago

Your rails version has security issues, please update as soon as possible!

Try to set openssl_verify_mode to false:
http://blog.tinle.org/?p=190

RE: hostname was not match with the server certificate - Added by Alain JUPIN almost 8 years ago

Hello

I've done this since my first post.
This is my config/environnement.rb

# Load the rails application
require File.expand_path('../application', __FILE__)

# Turn off auto TLS for e-mail
ActionMailer::Base.smtp_settings[:openssl_verify_mode] = false
ActionMailer::Base.smtp_settings[:enable_starttls_auto] = false

# Make sure there's no plugin in vendor/plugin before starting
vendor_plugins_dir = File.join(Rails.root, "vendor", "plugins")
if Dir.glob(File.join(vendor_plugins_dir, "*")).any?
  $stderr.puts "Plugins in vendor/plugins (#{vendor_plugins_dir}) are no longer allowed. " +
    "Please, put your Redmine plugins in the `plugins` directory at the root of your " +
    "Redmine directory (#{File.join(Rails.root, "plugins")})" 
  exit 1
end

# Initialize the rails application
RedmineApp::Application.initialize!

This doesn't solve my issue :( ???

Thanks for your message.

RE: hostname was not match with the server certificate - Added by Jan Niggemann (redmine.org team member) almost 8 years ago

Just to be sure: You restarted your instance after the config change, did you?

RE: hostname was not match with the server certificate - Added by Alain JUPIN almost 8 years ago

After each changes I restart by doing
service apache2 restart

I'm not really sure that it's OK.

Does redmine be restarted only by doing apache2 setart ?
Is there anyother command to restart redmine (or rails) ?

Redmine is running trought Apache2 with mod_passenger.

RE: hostname was not match with the server certificate - Added by Alain JUPIN almost 8 years ago

I've tried with :
touch /usr/share/redmine/tmp/restart.txt

But the file is not deleted when loading redmine webpages !
and I don't think that redmine was restarted

RE: hostname was not match with the server certificate - Added by Jan Niggemann (redmine.org team member) almost 8 years ago

No, that's OK, the file doesn't get deleted after the restart, it just stays there.

Sorry I can't help you further.

I noticed something: You wrote the filename as config/environnement.rb, but it's meant to be environment.rb. Is the filename in your installation correct?

RE: hostname was not match with the server certificate - Added by Alain JUPIN almost 8 years ago

Thanks for your help,

It's the file config/environment.rb (sorry I'm French and I've translated the filename when writing it :/ )

RE: hostname was not match with the server certificate - Added by Jan Niggemann (redmine.org team member) almost 8 years ago

J'avais compris :-)

I googled a bit, but you already tried everything I find.
Did you try to set the delivery method to sendmail?

(1-8/8)