Redmine.pm not working with LDAP and OS X Open Directory

Added by Todd Nine over 11 years ago

Hi all,
I have set up Redmine.pm to link my subversion auth to redmine. This is working very well for users that are authenticated in via the database. However, whenever I have a user who is added to a project as a manager, they cannot log in if their auth information comes from OSX Open Directory server. I have the Open Directory server configured in Redmine correctly. My users are automatically getting logged in and created if they don't exist and their details are pulled from Open Directory. I don't receive any errors in my apache logs other than auth denied. I just can't log in with LDAP authenticated users using the perl module. Has anyone else experienced this? What can I give to help diagnose the issue?

Thanks,
Todd

CentOS 5.3
Apache 2.2
Ruby 1.8.5
Redmine 0.8.0

Replies (2)

RE: Redmine.pm not working with LDAP and OS X Open Directory - Added by Todd Nine over 11 years ago

Hi all,
I forgot to mention before, I have installed Authen::Simple::LDAP via cpan. I wasn't able to find it in RPM format, so had to use the CPAN interactive shell to install it. Just to be sure the module was installed, I rebooted. Everything appears to be installed correctly, is there a diagnostic log I can enable on the auth to find out if the module is being correctly recognized?

RE: Redmine.pm not working with LDAP and OS X Open Directory - Added by Todd Nine over 11 years ago

Apparently my CPAN module didn't take correctly. I removed it then re-installed it, and now my module works. The wiki may need to be updated to outline the CPAN modules that need installed in order to make the LDAP auth work.

(1-2/2)