Mail notification does not work for Microsoft Exchange

Added by Maoke Jackson over 6 years ago

Hi,

I installed Redmine 2.6.1 in Windows 2008 R2. The mail server is Microsoft Exchange.
I follow the instruction in wiki to configure for MS Exchange server as below.

      address: <address>
      port: 25
      domain: <domain>
#      authentication: :login
#      user_name: "<username>" 
#      password: "<password>" 
#      enable_starttls_auto: false
#      openssl_verify_mode: none

However, by sending test mail, it shows "550 5.7.1 Unable to relay".

I also tried below configurations but all of them show "550 5.7.1 Unable to relay".

      address: <address>
      port: 25
      domain: <domain>
#      authentication: :login
#      user_name: "<username>" 
#      password: "<password>" 
      enable_starttls_auto: false
      openssl_verify_mode: none
      address: <address>
      port: 25
#      domain: <domain>
#      authentication: :login
#      user_name: "<username>" 
#      password: "<password>" 
      enable_starttls_auto: false
      openssl_verify_mode: none
      address: <address>
      port: 25
#      domain: <domain>
#      authentication: :login
#      user_name: "<username>" 
#      password: "<password>" 
      enable_starttls_auto: false
#      openssl_verify_mode: none

Then I tried these and they show "504 5.7.4 Unrecognized authentication type".

      address: <address>
      port: 25
      domain: <domain>
      authentication: :login
      user_name: "<username>" 
      password: "<password>" 
      enable_starttls_auto: false
#      openssl_verify_mode: none
      address: <address>
      port: 25
      domain: <domain>
      authentication: :login
      user_name: "<username>" 
      password: "<password>" 
      enable_starttls_auto: false
      openssl_verify_mode: none

Any help is appreciated.

Regards,
MJ

Replies (1)

RE: Mail notification does not work for Microsoft Exchange - Added by Tony Ordner over 6 years ago

It is probably the exchange server not allowing the relay. Talk to the exchange administrator to find either have them allow this or provide you with the config needed to relay.

(1-1/1)