Restore crashed v2 to v3

Added by R P about 3 years ago

I had a redmine v2 (I think 2.4) install on a Raspberry-Pi Jessie. There was a major corruption of the SD card and the machine crashed. I was able to recover a fair amount of the configuration, in particular the MySQL ibdata1 file. However, many of the redmine files are corrupted.

I have now installed v3.3.3 on another Pi and would like to try and restore my old configuration. I am not really interested in the stored data, just the screen configurations, etc. I tried replacing the new MySQL database with the old one, and redmine will actually start, but I cannot login or view projects. I also tried a migration [bundle exec rake db:migrate RAILS_ENV=production] but that fails with:
  • Mysql2::Error: Got error -1 from storage engine: ALTER TABLE `trackers` ADD `default_status_id` int(11)

I would gladly reinstall a v2 redmine and then upgrade later, but v2.x is no longer available.

Any ideas or suggestions most gratefully accepted.