Service Unavailable

Added by Taric Sam about 2 years ago


today i installed Redmine with the How to on this Site (

Installed Apps:
- Apache2
- MariaDB
- All Requirements (ruby, gem, etc.)

Path /opt/redmine/ - Ok
Link ln -s /var/www/redmine /opt/redmine/public - OK
Bundle Install run bundle install --without development test rmagick - OK
Database - Ok
Configure Apache2 - OK

ProxyPass /redmine http://real-redmine-server.localdomain:3000/
ProxyPassReverse /redmine http://real-redmine-server.localdomain:3000/

My Server is a Univention Corporate Server and i have a Proxypass. Redmine should use https://adress/redmine/

the Proxypass i got from:

ProxyPass /redmine
ProxyPassReverse /redmine

If i try to connect to the Site, i got this Apache error:

[Sat Apr 14 15:12:54.720392 2018] [proxy_http:error] [pid 32498] [client] AH01114: HTTP: failed to make connection to backend:, referer: https://adress/univention/portal/
[Sat Apr 14 15:13:07.294467 2018] [proxy:error] [pid 29798] (111)Connection refused: AH00957: HTTP: attempt to connect to ( failed
[Sat Apr 14 15:13:07.294520 2018] [proxy_http:error] [pid 29798] [client] AH01114: HTTP: failed to make connection to backend:, referer: https://adress/univention/portal/

i tried this:

Working variant (Sun Jun 26 13:48:50 MSK 2016)

Change the following lines at the bottom of your config/environment.rb

  1. Initialize the Rails application


RedmineApp::Application.routes.default_scope = "/redmine"
  1. Initialize the Rails application

Dont work

I tried this:

Redmine::Utils::relative_url_root = "/redmine"

Dont work

Redmine production.log

Started GET "/redmine/" for at 2018-04-14 14:25:19 +0200

ActionController::RoutingError (No route matches [GET] "/redmine"):
actionpack (4.2.8) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
actionpack (4.2.8) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
railties (4.2.8) lib/rails/rack/logger.rb:38:in `call_app'
railties (4.2.8) lib/rails/rack/logger.rb:20:in `block in call':
activesupport (4.2.8) lib/active_support/tagged_logging.rb:68:in `block in tagged'
activesupport (4.2.8) lib/active_support/tagged_logging.rb:26:in `tagged'
activesupport (4.2.8) lib/active_support/tagged_logging.rb:68:in `tagged'
railties (4.2.8) lib/rails/rack/logger.rb:20:in `call'
actionpack (4.2.8) lib/action_dispatch/middleware/request_id.rb:21:in `call'
rack (1.6.9) lib/rack/methodoverride.rb:22:in `call'
rack (1.6.9) lib/rack/runtime.rb:18:in `call'
activesupport (4.2.8) lib/active_support/cache/strategy/local_cache_middleware.rb:28:in `call'
actionpack (4.2.8) lib/action_dispatch/middleware/static.rb:120:in `call'
rack (1.6.9) lib/rack/content_length.rb:15:in `call'
rack (1.6.9) lib/rack/sendfile.rb:113:in `call'
railties (4.2.8) lib/rails/engine.rb:518:in `call'
railties (4.2.8) lib/rails/application.rb:165:in `call'
rack (1.6.9) lib/rack/lock.rb:17:in `call'
rack (1.6.9) lib/rack/content_length.rb:15:in `call'
rack (1.6.9) lib/rack/handler/webrick.rb:88:in `service'
/usr/lib/ruby/2.3.0/webrick/httpserver.rb:140:in `service'
/usr/lib/ruby/2.3.0/webrick/httpserver.rb:96:in `run'
/usr/lib/ruby/2.3.0/webrick/server.rb:296:in `block in start_thread'

My Browser shows: 503 Service unavailable

I dont know, why it wont work.

may u help me?

Best Regards