SMTP Notification emails incomplete and won't send

Added by Jason Fox over 2 years ago

Hi everyone,

We're running Redmine 3.4.3 on Ubuntu 16.04 LTS with postfix. An issue started within the last two weeks where notification emails began failing. Test emails work fine and I can receive them. After digging through logs and SMTP transactions I believe I have found the problem.

It seems that when sending the text of the email, the transmission stops after a certain number of characters and leaves the SMTP connection to time out. Since test emails are short they go through. Notifications are longer so they do not. I have tried postfix and sendmail with no change. I am watching Redmine communicating with postfix when this happens. Up until two weeks ago this all worked fine. Guessing that some ubuntu update has broken it but no idea what to look for.

Also noticed that short emails end with "." to the SMTP server as they should. Longer notification emails do not. Redmine just issues an SMTP QUIT.

My configuration.yml is attached. All this runs on an internal server behind our local firewall to the company network, so security is pretty low.

Thanks for any help. I'm ripping my hair out and without notification emails the staff is not keeping up with tasks.


jason@opt740:/opt/redmine/redmine-3.4.3$ RAILS_ENV=production bin/about

sh: 1: darcs: not found
sh: 1: hg: not found
sh: 1: bzr: not found
Redmine version 3.4.3.stable
Ruby version 2.4.2-p198 (2017-09-14) [x86_64-linux]
Rails version 4.2.8
Environment production
Database adapter Mysql2
Subversion 1.9.3
Cvs 1.12.13
Git 2.7.4
Redmine plugins:
no plugin installed

configuration.yml Magnifier (8.24 KB)