Incompatible date format in contextual menu and calendar

Added by Khemis Ratsimivony almost 2 years ago

Incompatible date format in contextual menu and calendar

Hello guys,

I tried for multiple weeks now to make redmine works on our production server but I am at a point where I can no longer progress by myself.

I was able to make multiple versions of redmine work with different configurations (OS,ruby,rails,postgres version) using a local database, but when I try to use those instances with our dev database or production database, some functionnalities fails.


1) In issues view, using contextual menu (right click) on an issue row to directly update a field (eg: status,tracker...etc) leads to an error message saying:

Failed to save 1 issue(s) on 1 selected: #2.
    Start date is not a valid date: #2
    Due date is not a valid date: #2

the issue is not updated

2) gantt view leads to a blank page with the following message in the logs

500 internal error
can't convert date into exact number

3) calendar doesn't show any issues

Solutions tested

According to the log, it's a date format problem. Most probably coming from my enterprise's databases. So I tried many ways to update it by following many posts I saw on internet (redmine forum, stackoverflow, github...etc)

Our current configuration at the office is using french format (dd/mm/yyyy), but I tested both "fr" and "en" format everywhere.

  • update date format in:
    • database
    • redmine application (running web application)
    • redmine configuration files ($REDMINE_HOME/config/)
    • redmine javascript files
    • redmine ruby files
  • create database from redmine migrate script
  • export a working database (local) with pg_dump to restore on dev/prod databases

either the application doesn't start (maybe because I have no experience on ruby and I am 100% sure how to edit ruby files), or the changes have no effect and the same errors appear again.

I also tried many versions of redmine to see if any would fix this but no luck.

I tried multiple version of postgresql on localhost, all of them are working localy but when I try to migrate to our dev/prod databases,the previous errors come up.

Our dev/production databases alreay have working applications (php and java) working on it and have no issues to this day.

Configurations tested

  • redmine: [ 3.2.0 , 3.4.6 , 3.4.8 , 4.0.2 ]
  • postgresql: [ 9.2 , 9.5 , 9.6 , 10.4 ]
  • ruby 2.4
  • rails: [ 4.2 , 5.2 ]
  • centos : [ 6 , 7 ]
  • oracle linux: 6

Production Setup (goal)

OS: Oracle Linux 6
Ruby: 2.4
Rails: 4.2
Redmine: 3.4.8
Environment: production

database: postgresql 9.5

webserver: puma 3.7

May someone have any clue on how I can solve this? thanks