Failed to start Network Time Synchronization.

Added by manlsea Zheng 5 months ago

OS:Linux raspberrypi 4.19.97-v7l+ #1294 SMP Thu Jan 30 13:21:14 GMT 2020 armv7l GNU/Linux

After the Postgresql and SVN are installed, The system was normal; Execute "timedatectl set-ntp true" OK;

However, After installing redmine V4.1.1, and it works; but we found that there was a problem with the system time; Execute "timedatectl set-ntp true" failed;

As follows

pi@raspberrypi:~ $ sudo timedatectl set-ntp true
Failed to set ntp: Failed to activate service 'org.freedesktop.timedate1': timed out (service_start_timeout=25000ms)
pi@raspberrypi:~ $ sudo timedatectl set-ntp true
Failed to set ntp: timed out
pi@raspberrypi:~ $ sudo systemctl status systemd-timesyncd.service
Warning: The unit file, source configuration file or drop-ins of systemd-timesyncd.service changed on disk. Run 'systemctl dae
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
  Drop-In: /lib/systemd/system/systemd-timesyncd.service.d
           └─disable-with-time-daemon.conf
   Active: failed (Result: resources) since Mon 2020-05-04 12:28:59 CST; 1min 58s ago
     Docs: man:systemd-timesyncd.service(8)

5月 04 12:28:59 raspberrypi systemd[1]: systemd-timesyncd.service: Service has no hold-off time (RestartSec=0), scheduling res
5月 04 12:28:59 raspberrypi systemd[1]: systemd-timesyncd.service: Scheduled restart job, restart counter is at 5.
5月 04 12:28:59 raspberrypi systemd[1]: Stopped Network Time Synchronization.
5月 04 12:28:59 raspberrypi systemd[1]: systemd-timesyncd.service: Start request repeated too quickly.
5月 04 12:28:59 raspberrypi systemd[1]: systemd-timesyncd.service: Failed with result 'resources'.
5月 04 12:28:59 raspberrypi systemd[1]: Failed to start Network Time Synchronization.

How to solve it, thanks.