upgrading issues from redmine-3.3.3 to redmine-4.1.stable

Added by Amir SALTANATKHAH about 1 month ago

Hi Everyone,

I really need some help ...

I'm trying to upgrade Redmine from v 3.3.3 to the last version ( 4.1 stable )
I was able to install, Curl, RVM, and SVN.
I upgraded ruby (rvm install ruby-2.6.5) (ruby -v ==> ruby 2.6.5p114 (2019-10-01 revision 67812) [x86_64-linux])
I have downloaded the last stable version on Redmine frome SVN ( svn co http://svn.redmine.org/redmine/branches/4.1-stable )
Copied database and configuration from the old version to the new (

cp /opt/redmine/redmine-3.3.3/config/configuration.yml /opt/redmine/redmine-4.1.stable/config/
cp /opt/redmine/redmine-3.3.3/config/database.yml /opt/redmine/redmine-4.1.stable/config/

when i'm going to the folder /opt/redmine/redmine-4.1.stable i have this Warning message :

RVM used your Gemfile for selecting Ruby, it is all fine - Heroku does that too,
you can ignore these warnings with 'rvm rvmrc warning ignore /opt/redmine/redmine-4.1.stable/Gemfile'.
To ignore the warning for all files run 'rvm rvmrc warning ignore allGemfiles'.

Unknown ruby interpreter version (do not know how to handle): >=2.3.0,<2.7.0ifBundler::VERSION>=1.12.0.

by th way i have upgraded gems (gem install bundler gem install passenger)

Now, when i'm trying to upgrade, to do bundle install ( i'm in the /opt/redmine/redmine-4.1.stable ) i have this erros :

There was an error while trying to write to `/opt/redmine/redmine-4.1.stable/.bundle/config`. It is likely that you need to grant write permissions for that path.

I gave a chmod 777 -R to the whole folder , but i'm still having the same PB ( and the folder .bundle does not exist ... )

What to do ? :'(

Thanks for your help.

Amir.