Issues after upgrade from 3.4.5 to 4.1.1

Added by Max Hewitt 5 months ago

Hello everyone!

A week ago I upgraded redmine from 3.4.5 to 4.1.1. Everything seems to be ok but there're several issues I would like you to help me with.

So, the issues:
  1. There're messages in production.log
      ActionController::RoutingError (No route matches [GET] "/images/bullet_arrow_left.png"):
      ActionController::RoutingError (No route matches [GET] "/images/arrow_expanded.png"):
      ActionController::RoutingError (No route matches [GET] "/images/arrow_collapsed.png"):
      ActionController::RoutingError (No route matches [GET] "/images/bullet_arrow_right.png"):
      ActionController::RoutingError (No route matches [GET] "/version"):
      ActionController::RoutingError (No route matches [GET] "/favicon.ico%3F1530011900"):
    

    I fixed those ones about /images/ by downloading them from http://svn.redmine.org/redmine/branches/3.4-stable/public/images/
    but I think that it's not the right way it should be fixed.
  2. This is how I see "Filters" and "Options" when I open an issue list (/issues):

    An arrow near "Options" indicates that options should be collapsed, but they're not. The same situation with a project list (/projects).
  3. Sometimes, when I open redmine directory I get this warning:
    [root@redmine tmp]# cd /var/www/redmine/log/
    RVM used your Gemfile for selecting Ruby, it is all fine - Heroku does that too,
    you can ignore these warnings with 'rvm rvmrc warning ignore /var/www/redmine/Gemfile'.
    To ignore the warning for all files run 'rvm rvmrc warning ignore allGemfiles'.
    
    Unknown ruby interpreter version (do not know how to handle): >=2.3.0,<2.7.0ifBundler::VERSION>=1.12.0.
    [root@redmine log]#
    [root@redmine log]# bundler --version
    The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x64-mingw32, x86-mswin32. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x64-mingw32 x86-mswin32`.
    The dependency ffi (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x64-mingw32, x86-mswin32. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x64-mingw32 x86-mswin32`.
    Bundler version 1.17.3
    [root@redmine log]#
    
    

rm.png (22.8 KB)