Error while installing plug-in

Added by Abhijeet Mule 23 days ago

Hi Experts,

I am trying to install the plugin(xlsx file exporter, email checker etc) to Redmine 3.4.4 version and it gives me below error. Ruby version is ruby 2.4.3p205 (2017-12-14 revision 61247) [x64-mingw32]

Command used: ===========
bundle install --without development test --no-deployment

bundle exec rake redmine:plugins NAME=redmine_xlsx_format_issue_exporter RAILS_ENV=production

Error: ===========
D:\gmine\redmine>bundle exec rake redmine:plugins NAME=redmine_xlsx_format_issue_exporter RAILS_ENV=production
rake aborted!
LoadError: cannot load such file -- mysql2/2.4/mysql2
D:/gmine/redmine/config/application.rb:5:in `<top (required)>'
D:/gmine/redmine/Rakefile:5:in `require'
D:/gmine/redmine/Rakefile:5:in `<top (required)>'
(See full trace by running task with --trace)

With Trace enabled:

D:\gmine\redmine>bundle exec rake redmine:plugins NAME=redmine_xlsx_format_issue_exporter RAILS_ENV=production --trace
rake aborted!
LoadError: cannot load such file -- mysql2/2.4/mysql2
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/mysql2-0.4.10-x64-mingw32/lib/mysql2/mysql2.rb:2:in `require'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/mysql2-0.4.10-x64-mingw32/lib/mysql2/mysql2.rb:2:in `<top (required)>'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/mysql2-0.4.10-x64-mingw32/lib/mysql2.rb:31:in `require'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/mysql2-0.4.10-x64-mingw32/lib/mysql2.rb:31:in `<top (required)>'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/runtime.rb:81:in `require'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/runtime.rb:81:in `block (2 levels) in require'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/runtime.rb:76:in `each'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/runtime.rb:76:in `block in require'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/runtime.rb:65:in `each'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/runtime.rb:65:in `require'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler.rb:114:in `require'
D:/gmine/redmine/config/application.rb:5:in `<top (required)>'
D:/gmine/redmine/Rakefile:5:in `require'
D:/gmine/redmine/Rakefile:5:in `<top (required)>'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/rake-12.3.0/lib/rake/rake_module.rb:29:in `load'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/rake-12.3.0/lib/rake/rake_module.rb:29:in `load_rakefile'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:703:in `raw_load_rakefile'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:104:in `block in load_rakefile'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:186:in `standard_exception_handling'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:103:in `load_rakefile'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:82:in `block in run'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:186:in `standard_exception_handling'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:80:in `run'
D:/gmine/Ruby24/lib/ruby/gems/2.4.0/gems/rake-12.3.0/exe/rake:27:in `<top (required)>'
D:/gmine/Ruby24/bin/rake:23:in `load'
D:/gmine/Ruby24/bin/rake:23:in `<main>'

has anybody seen this issue? Can you please help?

-Abhi