Process to update version of ruby

Added by Eduardo HM 9 months ago

Hello

I have the following Redmine environment mounted on a RHE 7

Environment:
Redmine version 4.1.0.stable
Ruby version 2.3.8-p459 (2018-10-18) [x86_64-linux]
Rails version 5.2.4.1
Environmental production
Mysql2 database adapter
Mail Queue ActiveJob :: QueueAdapters :: AsyncAdapter
Shipping via smtp mail
SCM:
Git 1.8.3.1
File System
GitRemote 1.8.3.1
Redmine Plugins:
custom_field_sql 1.0
plugin_ans v1.3.0
portfolio_timeline v2.5.2
redmine_backlogs v1.1.2
redmine_contacts 4.3.4
redmine_contacts_helpdesk 4.1.12
redmine_git_remote 0.0.1
redmine_information 1.1.0
redmine_more_previews 2.0.7
redmine_wiki_lists 0.0.9

I need to do a Ruby version upgrade, as one of the plugins requires Ruby version 2.5 for certain kinds of functions they use.

What is the procedure to update Ruby version 2.3.8 to version 2.5?

Kind regards.

Replies (1)

RE: Process to update version of ruby - Added by C S 9 months ago

Ruby is not part of Redmine but the programming language used. Have a look here:

https://edgeguides.rubyonrails.org/upgrading_ruby_on_rails.html

(1-1/1)