Trying to setup redmine:email:receive_imap on a Bitnami 4.2.3

Added by Gael Duret 5 months ago

Hello All,

Trying to follow up instruction on page https://www.redmine.org/projects/redmine/wiki/RedmineReceivingEmails#Target-Project-from-Email-Sub-Address without any knowledge of python language. No success.

I'm using a windows server 2012.

Running this command from the command line I find in "RedMine packaged by Bitnami" :

rake -f C:\Bitnami\redmine-4.2.3-3\ruby\lib\ruby\gems\2.6.0\gems\vcard-0.3.0\Rakefile redmine:email:receive_imap ssl=SSL RAILS_ENV="production" port=993 host=outlook.office365.com username=xxxxx  password=yyyyy allow_override=project,tracker,status,priority --trace

Log is:

rake aborted!
Unable to determine name from existing gemspec. Use :name => 'gemname' in #install_tasks to manually set it.
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.3.13/lib/bundler/gem_helper.rb:36:in `initialize'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.3.13/lib/bundler/gem_helper.rb:15:in `new'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.3.13/lib/bundler/gem_helper.rb:15:in `install_tasks'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/bundler-2.3.13/lib/bundler/gem_tasks.rb:7:in `<top (required)>'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/vcard-0.3.0/Rakefile:1:in `<top (required)>'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/rake-13.0.6/lib/rake/rake_module.rb:29:in `load'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/rake-13.0.6/lib/rake/rake_module.rb:29:in `load_rakefile'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/rake-13.0.6/lib/rake/application.rb:710:in `raw_load_rakefile'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/rake-13.0.6/lib/rake/application.rb:104:in `block in load_rakefile'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/rake-13.0.6/lib/rake/application.rb:186:in `standard_exception_handling'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/rake-13.0.6/lib/rake/application.rb:103:in `load_rakefile'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/rake-13.0.6/lib/rake/application.rb:82:in `block in run'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/rake-13.0.6/lib/rake/application.rb:186:in `standard_exception_handling'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/rake-13.0.6/lib/rake/application.rb:80:in `run'
C:/Bitnami/redmine-4.2.3-3/ruby/lib/ruby/gems/2.6.0/gems/rake-13.0.6/exe/rake:27:in `<top (required)>'
C:/Bitnami/redmine-4.2.3-3/ruby/bin/rake:23:in `load'
C:/Bitnami/redmine-4.2.3-3/ruby/bin/rake:23:in `<main>'

I have no idea what mean : Unable to determine name from existing gemspec. Use :name => 'gemname' in #install_tasks to manually set it.

Any help will be welcome.

Thanks