Problem with linking to gsl library

Added by Juri Fiaschi 2 months ago

Hi, I am experiencing a problem in the compilation of the RESUMMINO code on IRIDIS5.
The code requires the following modules, that I am loading before the compilation:
cmake, boost, gsl

After pre-configuring the installation with cmake, I proceed with the compilation and everything goes smooth until the end when I get the following message:

"
/usr/bin/ld: warning: libgfortran.so.3, needed by //usr/lib64/atlas/libsatlas.so.3, may conflict with libgfortran.so.5
liblibresummino.a(pdf.cc.o): In function `Fit(double*, double*, int, double, double, double, double, double, double)':
pdf.cc:(.text+0x2f8e): undefined reference to `gsl_multifit_fdfsolver_jac'
collect2: error: ld returned 1 exit status
make2: * [bin/resummino] Error 1
make1:
[src/CMakeFiles/resummino.dir/all] Error 2
make: *
* [all] Error 2
"

it is very weird that the "gsl_multifit_fdfsolver_jac" function is not found, as it is definitely there.
I made sure the gsl path is correct (also no problem has been found during the compilation where several gsl functions are called frequently in the code).
I have tried different versions of gsl as well, all giving the same error.

Please provide with some support.
If more info are needed, just let me know.
Thanks!