Upgrade 4.1.1 to 5.0.1 filters for issues do not work

Added by Gary Aitken about 1 month ago

I'm trying to upgrade from:

  redmine 4.1.1
  rails 5.2.4.2
  mysql 5.7
  ruby 2.6.6-p46
  ubuntu-18.04

to:
  redmine 5.0.1
  rails 6.1.6
  mysql 5.7
  ruby 3.0.4-p208
  ubuntu-20.04

The original redmine had plugins installed.
I uninstalled all plugins and verified that things still worked.
I then dumped the db and tarred up the files.

On the new, empty system, I:

  backed out the migrations so they were where the 4.1.1 system was
    I don't know if this is necessary or not.
  restored the files and the db
  migrated the db.

The migration seemed to go ok.
The new redmine comes up ok, looks ok, except:

If I go to a project and click on the issues tab, 
the "v Filters" label shows up but the filter itself is missing --
  no checkbox, "Status" or "Open" dropdown
  (the Add Filter dropdown displays).
1. Clicking on the "Filters" label has no affect;
2. The add filter dropdown displays, but adding a filter does not add anything to the filters display.
3. Clicking on "Options" has no effect.
(Clicking "New issue" seems to work.)

I have tried comparing the schemas of before and after and the diffs all look something like this:

15c15
<   create_table "attachments", id: :integer, charset: "utf8mb4", force: :cascade do |t|
---
>   create_table "attachments", id: :integer, charset: "utf8mb4", collation: "utf8mb4_unicode_ci", force: :cascade do |t|
25c25
<     t.timestamp "created_on" 
---
>     t.datetime "created_on" 

and

<     t.text "path", null: false
<     t.text "from_path" 
---
>     t.text "path", size: :medium, null: false
>     t.text "from_path", size: :medium

I'm somewhat concerned about the size changes, but I suspect that is not the issue; they are all text fields.
Suggestions / thoughts?