Propose new scheme for plugins using database tables

Added by vitaly endors over 13 years ago

Because of problems with conflicts and also maintenance (difficult to tell what uses a table), I want to suggest that all plugins which add tables use a prefix of some kind. So if your project is called "contacts" you can be cont_[table name] instead of [table_name].

This way "appointments" becomes "cont_appointments". Yes, it is a little harder to code, but you will make it easier on everyone to maintain or use your project.

A very nice programmer would provide a script to migrate data from existing table names to new table names.
It is just an idea.