Defect #11166

PotgreSQL required version for redMine-2.x.x

Added by Nabil Faouzi over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Database
Target version:-
Resolution:Fixed Affected version:2.0.1

Description

Hello,

I think they are an error in the installation page for 1.4.x and 2.x.x version of redmine.

The postgreSQL requirement is false, i've migrated since 1.4.3 to 2.0.1 (migrated ruby and rails too with all delegate gems) and the command rake returns:

*(Your version of PostgreSQL (80111) is too old, please upgrade!)*
        from /usr/local/lib/ruby/gems/1.9.1/gems/activerecord-3.2.3/lib/active_record/connection_adapters/postgresql_adapter.rb:334:in `initialize'
        from /usr/local/lib/ruby/gems/1.9.1/gems/activerecord-3.2.3/lib/active_record/connection_adapters/postgresql_adapter.rb:28:in `new'
        from /usr/local/lib/ruby/gems/1.9.1/gems/activerecord-3.2.3/lib/active_record/connection_adapters/postgresql_adapter.rb:28:in `postgresql_connection'

My PostgreSQL Server version is 8.1.11, please change this requirement:

_PostgreSQL 8 or higher

make sure your database datestyle is set to ISO (Postgresql default setting). You can set it using: ALTER DATABASE "redmine_db" SET datestyle="ISO,MDY";
some bugs in PostgreSQL 8.4.0 and 8.4.1 affect Redmine behavior (#4259, #4314), they are fixed in PostgreSQL 8.4.2
_

Nabil.

History

#1 Updated by Etienne Massip over 9 years ago

  • Assignee deleted (Jean-Philippe Lang)

#2 Updated by Etienne Massip over 9 years ago

  • Status changed from New to Closed

Thanks, updated RedmineInstall according to statement PostgreSQL adapter only supports PostgreSQL version 8.2 and higher in AR CHANGELOG.

Also available in: Atom PDF