Defect #12052

Line reference for source code in git repository defunct

Added by Michael Aye almost 7 years ago. Updated almost 7 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:-
Resolution:Cant reproduce Affected version:2.0.3

Description

Symptom:

Started GET "/projects/diviner/repository/entry/p3dgeom.f%23170" for 128.97.245.186 at Tue Oct 09 08:22:49 -0700 2012
Processing by RepositoriesController#entry as HTML
Parameters: {"id"=>"diviner", "path"=>"p3dgeom.f#170"}
Rendered common/error.html.erb within layouts/base (0.1ms)
Completed 404 Not Found in 536ms (Views: 37.7ms | ActiveRecord: 109.8ms)

My environment:
Redmine 2.0.3 stable
git 1.7.1
Output of 'rake about':

Ruby version 1.8.7 (x86_64-linux)
RubyGems version 1.8.24
Rack version 1.3
Rails version 3.2.6
Active Record version 3.2.6
Action Pack version 3.2.6
Active Resource version 3.2.6
Action Mailer version 3.2.6
Active Support version 3.2.6

(Question about category: Why don't you guys have a Repository category?)

History

#1 Updated by Michael Aye almost 7 years ago

In case you don't trust that the reference works at all:


Started GET "/projects/diviner/repository/entry/p3dgeom.f" for 128.97.245.186 at Tue Oct 09 08:30:27 -0700 2012
Processing by RepositoriesController#entry as HTML
Parameters: {"id"=>"diviner", "path"=>"p3dgeom.f"}
Rendered repositories/_navigation.html.erb (20.5ms)
Rendered repositories/_breadcrumbs.html.erb (1.7ms)
Rendered repositories/_link_to_functions.html.erb (3.2ms)
Rendered common/_file.html.erb (25.9ms)
Rendered repositories/entry.html.erb within layouts/base (53.5ms)
Completed 200 OK in 401ms (Views: 90.3ms | ActiveRecord: 7.4ms)

#2 Updated by Toshi MARUYAMA almost 7 years ago

  • Category set to SCM

#3 Updated by Etienne Massip almost 7 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce

The anchor name is #L170 (with a heading L).

E.g. source:/trunk/Gemfile#L50.

#4 Updated by Michael Aye almost 7 years ago

oh, darn PEBKAC.. Thanks...

Also available in: Atom PDF