Project

General

Profile

Actions

Defect #14906

open

Excessive queries on roles table when show a Issue

Added by Maicon Zucco over 10 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Issues
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Affected version:

Description

Hi,

Monitoring the Redmine MySQL queries from Redmine app I found a lot of queries on table roles.
For each member in project is executed a query below (changed the member_id) when I access the page "redmine/issues/xxxx":

SELECT `roles`.* FROM `roles` INNER JOIN `member_roles` ON `roles`.`id` = `member_roles`.`role_id` WHERE `member_roles`.`member_id` = 2310

The problem is that there are about 500 members in the issue project.

It’s possible to otimize this process?

Thanks.


Related issues

Related to Redmine - Defect #17700: Excessive DB querying when Allow Group Issue Assignment is enabledNew

Actions
Actions #1

Updated by Maicon Zucco over 10 years ago

  • Status changed from New to Resolved

Hi,

I found the "problem". I have selected the option "Allow issue assignment to groups".
After unselected this, the excessive queries was finished.

Thanks.

Actions #2

Updated by Jan Niggemann (redmine.org team member) over 9 years ago

  • Related to Defect #17700: Excessive DB querying when Allow Group Issue Assignment is enabled added
Actions #3

Updated by redmineservices . over 8 years ago

This problem also occurs when you have a custom field with user format.

Actions

Also available in: Atom PDF