Defect #19467

Downloading attachments will be wrong if the file names contain more than two chinese characters

Added by micro bead over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate Affected version:

Description

If the file names contain more than two chinese characters, downloading attachments will be wrong, and http 500 error will be occured.
Would anybody help me?
thx

redmine2.jpg (34.7 KB) micro bead, 2015-03-24 12:44

redmine.jpg (28.2 KB) micro bead, 2015-03-24 12:44


Related issues

Duplicates Redmine - Defect #19374: MinGW thin and puma: Internal server error occoures when ... Closed

History

#1 Updated by Toshi MARUYAMA over 7 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Duplicate of #19374.

#2 Updated by Toshi MARUYAMA over 7 years ago

  • Duplicates Defect #19374: MinGW thin and puma: Internal server error occoures when attachment file name contains non ASCII added

#3 Updated by micro bead over 7 years ago

  • Status changed from Closed to Reopened

two chinese characters can work,but more than two ones will be wrong.

#4 Updated by micro bead over 7 years ago

have solved the problem
open the following file and add some codes
D:\Bitnami\redmine-3.0.0-0\apps\redmine\htdocs\vendor\bundle\ruby\2.0.0\gems\actionpack-4.2.0\lib\action_dispatch\middleware
if match = paths.detect { |p|
path = File.join(@root, p)
begin
File.file?(path) && File.readable?(path)
rescue SystemCallError
false
rescue EncodingError
false
end
}

#5 Updated by Toshi MARUYAMA over 7 years ago

  • Status changed from Reopened to Closed

#6 Updated by Toshi MARUYAMA over 7 years ago

  • Resolution changed from Invalid to Duplicate

#7 Updated by Toshi MARUYAMA over 7 years ago

Also available in: Atom PDF