Defect #30104


Cannot change Project inside Issue

Added by Oleg Blyahher over 5 years ago. Updated over 5 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:
Affected version:


Hi there,

Running Redmine 3.6.4 on Debian 9 with Apache and Phusion Passenger running.

When running rails -v and ruby -v I get Rails 4.2.8 and ruby 2.4.4p296, respectively.

I've recently migrated the database from a quite old installation of Redmine (2.5.2) to a new one. Had no issues whatsoever.

I have 2 plugins running: redmine_dashboard and redmine_ics_export. I have tried disabling/uninstalling those, but to no avail.

When I click 'Edit' on an issue, I can change many parameters under Change properties, but not the project. This is the error I see in the logs:

ActiveRecord::RecordNotFound (Couldn't find all IssueCategories with 'id': (all, {:joins=>:project, :conditions=>{:project_id=>[#<Project id: 55, name: "Components", description: "Python modules embedded in the platform. All ...",
homepage: "", is_public: false, parent_id: 26, created_on: "2014-12-16 08:32:05", updated_on: "2018-11-20 14:02:11", identifier: "nggg-components", status: 1, lft: 27, rgt: 28, inherit_members: true, inherit_categs: true, default_version_id: nil, default_assigned_to_id: nil>, #<Project id: 26, name: "Software", description: "Aka the \"Next Generation\" software.", homepage: "", is_public: false, parent_id: 14, created_on: "2013-05-31 07:01:59", updated_on: "2015-06-10 12:04:23", identifier: "nggg", status: 1, lft: 26, rgt: 41, inherit_members: false, inherit_categs: true, default_version_id: nil, default_assigned_to_id: nil>, #<Project id: 14, name: "Company R&D", description: "All Company research and development projects.", homepage: "", is_public: false, parent_id: nil, created_on: "2010-11-08 14:18:23", updated_on:
"2014-12-16 15:41:51", identifier: "research-development", status: 1, lft: 1, rgt: 70, inherit_members: false, inherit_categs: nil, default_version_id: nil, default_assigned_to_id: nil>]}, :order=>"name, projects.rgt"}) (found 0 results, but was looking for 2)):
app/models/project.rb:156:in `inherited_categories'
app/models/issue.rb:388:in `project='
app/models/issue.rb:358:in `project_id='
app/models/issue.rb:528:in `safe_attributes='
app/controllers/issues_controller.rb:478:in `update_issue_from_params'
app/controllers/issues_controller.rb:155:in `edit'
lib/redmine/sudo_mode.rb:63:in `sudo_mode'

Bundler says that it's Using activerecord 4.2.8. If I run gem list | grep record I get activerecord (5.2.2, 4.2.8, 4.2.0).

How do I fix this? Does this have to do with the Redmine version?

Thank you in advance.

Actions #1

Updated by Oleg Blyahher over 5 years ago

Small addition - pressing Save results in a 404 page not found error. Reloading the page afterwards brings the issue up again, unchanged.


Also available in: Atom PDF