Defect #7766

Author lost when issue is duplicated

Added by Alexis U. almost 9 years ago. Updated almost 9 years ago.

Status:ClosedStart date:2011-03-03
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Invalid Affected version:1.1.1

Description

When duplicating an issue, both the issue being duplicated and the new copy belong to the current user. The author of the source issue is lost.

If the user X creates the issue A, and then the user Y duplicates it as issue B, both issue A and B have now Y as author.

History

#1 Updated by Etienne Massip almost 9 years ago

  • Category changed from Issues workflow to Issues

Well, this makes sense since your are the real author of the new issue ?!

#2 Updated by Alexis U. almost 9 years ago

With the same example as before, X should still be the author of the issue A, and Y only the author of issue B.

#3 Updated by Etienne Massip almost 9 years ago

Ok, sorry, read too quickly.

But can't reproduce.

Do you use plugins / patches ?

#4 Updated by Alexis U. almost 9 years ago

Actually, yes, I am using these two plugins:
Redmine Close Button plugin (v 0.0.3)
Redmine Theme Changer plugin (v 0.0.2)

#5 Updated by Alexis U. almost 9 years ago

Hum, I can't reproduce it either, with or without the plugins.

Something must have been wrong with my way of testing.

Thank you, and sorry for the time lost.

#6 Updated by Etienne Massip almost 9 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

No problem.

Reopen this issue if ever you can reproduce the bug.

Also available in: Atom PDF