Project

General

Profile

Actions

Defect #7913

closed

Add Another file to ticket doesn't work in Firefox

Added by Cassiano Monteiro over 12 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Attachments
Target version:
-
Start date:
2010-07-22
Due date:
% Done:

0%

Estimated time:
Resolution:
Invalid
Affected version:

Description

Still got this problem on Firefox. The link "Add another file" points to "http://localhost/redmine/projects/red/issues/new#" .

Using Redmine 1.1.1 (stable) on Firefox 3.6.15 32-bit, Windows XP 64-bit.

Recurrence from issue #5935.

Actions #1

Updated by Etienne Massip over 12 years ago

Can't reproduce.

The link is correct, though.

Could you describe the behavior with some more details, please ?

Actions #2

Updated by Cassiano Monteiro over 12 years ago

On any screen that has the link "add another file" (issues, wiki, etc.), when you click nothing happens. Even if I already have one file selected through the "browse" button. That happens also on IE.

Here at the official Redmine (1.1.2 i think), when you click the link, another file box is shown, with another textbox for the file path and another "browse" button.

Actions #3

Updated by Etienne Massip over 12 years ago

Do you have plugins installed, did you modify some javascript files ?

Actions #4

Updated by Cassiano Monteiro over 12 years ago

Plugins installed:

Redmine Attach Screenshot 0.0.4
Redmine Charts 0.1.0
Redmine Time Tracker 0.4
Stuff To Do 0.4.0

I didnĀ“t do any modifications.

Actions #5

Updated by Etienne Massip over 12 years ago

Did you try to deactivate your plugins (specifically "Attach Screenshot") ?

Actions #6

Updated by Cassiano Monteiro over 12 years ago

You got it. I removed the plugin, and the link "add another file" worked. So actually it's not a Redmine bug, but a bug from the plugin. Sorry for not having realized that before.

Actions #7

Updated by Etienne Massip over 12 years ago

  • Status changed from New to Closed
  • Resolution changed from Fixed to Invalid

No problem.

Actions #8

Updated by Shaun Bader about 12 years ago

SPAM

Actions #9

Updated by Sri Ramireddy almost 12 years ago

Hello Guys, I am using the redmine in Safari and it still fails. I am Redmine 1.2.1 with the plugins- Stuff-to-do, To-dos, Redmine Backlogs and Wiki Extensions.

I kinda feel 'Add Another file' doesn't work even before installing the plugins. Not sure if it is a bug with the Redmine version 1.2.1

Actions #10

Updated by Sri Ramireddy almost 12 years ago

  • Status changed from Closed to Reopened
Actions #11

Updated by Anonymous over 10 years ago

Redmine 2.3.0
Add another file link doesn't work in Firefox nor in IE.
Javascript method addFileField() seems to be absent.

In my case, the reason is most likely in ScreenShot plugin.

Actions #12

Updated by Toshi MARUYAMA over 10 years ago

  • Status changed from Reopened to Needs feedback
Actions #13

Updated by Etienne Massip over 10 years ago

  • Status changed from Needs feedback to Closed

The file attachment behavior has been modified with 2.3.0 and this issue is no more applicable.

Actions

Also available in: Atom PDF