Defect #7958

Irregular CSV file (caused by "Description" field)

Added by Zbigniew Nowacki over 10 years ago. Updated over 10 years ago.

Status:ClosedStart date:2011-03-22
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Invalid Affected version:

Description

I have a problem with CSV export. It is because the field "Description" is export. It usually contains a long text with many CR-LF characters. During export all this CR-LF are put to CSV file. All of them create new lines in file. In consequence it is very irregular.
I think there are 3 possible solution:
1. Remove "Description" from export as unuseful
2. Remove or Replace CR-LF inside "Description" by any other character(s) while export
3. Use Custom query definnition to export only selected fields (like in PDF export) #4742
(I know there is a discussion about this export. Maybe the best way is to make possible to configure which kind of export is prefered by the user: all fields or selected fields).


Related issues

Duplicates Redmine - Defect #7039: CSV export. Line breaks. Excel Closed 2010-12-03

History

#1 Updated by Etienne Massip over 10 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Closed as duplicate of #7039.

Also available in: Atom PDF